To set IP address in Solaris you should first check if there is such network adapter. This can be done on many ways:
dmesg or from /var/adm/messages:
Sep 18 11:50:10 sun3 mac: [ID 469746 kern.info] NOTICE: e1000g3 registered
dladm:
e1000g3 link: up speed: 1000 Mbps duplex: full
prtconf:
dev_path=/pci@0,0/pci15ad,750@14:e1000g3 dev_link=/dev/e1000g3
Set in /etc/hosts record for this IP/hostname
10.0.1.32 yourhostname
Set netmask for this IP in /etc/netmasks
10.0.1.0 255.255.255.0
Next step is to set in /etc the file hostname.e1000g3 with content:
yourhostname netmask + broadcast + up
The previous three steps are done to have interface up on boot of the system
Plumb the interface
ifconfig e1000g3 plumb
And get it up and running
ifconfig e1000g3 `cat /etc/hostname.e1000g3`
To set your default gateway create file /etc/defaultrouter and put inside the IP address of your gateway
Subscribe to:
Post Comments (Atom)
Compressed tar archive
There are some cases when you want to create compressed tar archive but you do not have enough disk space to keep original files and tar arc...
-
To build firewall under AIX is sample, but as each host based firewall should be done careful 1. Prerequisites To start firewall in AIX yo...
-
There are some cases when you want to create compressed tar archive but you do not have enough disk space to keep original files and tar arc...
-
4. Its time for some system administrator tasks. Oracle ASM need special mark of disks will work with 4.1. Because of some reason (i don...
No comments:
Post a Comment